Platform Failures

Incident Report for Wheel

Resolved

This incident was resolved with the vendor releases on the morning of November 18th 2025.
Posted Nov 19, 2025 - 14:26 UTC

Update

Our services have recovered and are operational. Our vendor is still monitoring for any residual issues. We will continue monitoring.
Posted Nov 18, 2025 - 15:28 UTC

Update

Our vendor has announced they have potentially deployed a fix. We will monitor and verify our services are all fully operational.
Posted Nov 18, 2025 - 14:45 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 14:23 UTC

Monitoring

We are monitoring this issue.
Posted Nov 18, 2025 - 12:43 UTC

Update

We are continuing to monitor this issue.
Posted Nov 18, 2025 - 12:17 UTC

Identified

A critical vendor system is experiencing an outage. We will monitor and update as more information becomes available.
Posted Nov 18, 2025 - 12:12 UTC
This incident affected: Wheel Horizon Platform.